My SellerDeck Account | Newsletter | Free Trial

Community and Knowledge Base

  #1  
Old 15-Sep-2017, 03:55 AM
midwinter midwinter is offline
Registered User
Join Date: Jan 2010
Full Name: Ian Alcock
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Anyone using Worldpay (I can't integrate)

Hi,
I'm just in the very nearly stages of setting up a site using SD 2016 (having ground to a halt with SD 9 some years ago).

Can anyone please shed any light on worldpay integration and the secret key? I'ver searched the forums (several old threads), google, worldpay etc etc.

Worldpay deny all knowledge of such a thing, (though I have another email unanswered since Tuesday).

Sellerdeck support write:
'Looking at historical records, the integration was created by Worldpay in December 1998 and has periodically been updated to cater for different URLs/protocols etc. since that time. The original integration was created by a Simon Levitt (simon.levitt@uk.worldpay.com) at Worldpay.
I can see from previous support issues that the system they have created uses a 'MD5 hash key' as the secret key. Possibly your contact may be able to deduce the system from this information, however most customers as far as I can see from those previous support issues simply contact Worldpay and ask them if this account is suitable for using within SellerDeck.
I have not been able to find an instance previously where Worldpay has been contacted and the operative could not deal with the issue.'

I suppose I'm wondering if the inbuilt integration still works or if people are dropping in html integration code somewhere in their sites, rather than using the picking list in business settings busness settings.

Any help appreciated...
Many thanks
Ian

Last edited by midwinter; 16-Sep-2017 at 04:05 PM.. Reason: Update problem
Reply With Quote
  #2  
Old 15-Sep-2017, 07:16 AM
Mike Hughes Mike Hughes is offline
Registered User
Join Date: Jan 2003
Full Name: Mike Hughes
Posts: 7,963
Thanks: 258
Thanked 442 Times in 390 Posts
Is this the answer you're looking for?

Quote:

I've got it to work!

I entered the installation id in the 'Merchant ID' field and the Account ID (the one set to Test) in the Secret Key field.

I tried a radically new approach. I actually read the 'Setting Up' help provided by Worldpay! I should obviously have done this originally!
As the old saying goes: RTFM !

Thanks for your help.

Regards,

Fergus
From a previous thread here: http://community.sellerdeck.com/arch...p/t-17482.html
__________________
-----------------------------------------

First Tackle - Fly Fishing and Game Angling

-----------------------------------------
Reply With Quote
The Following User Says Thank You to Mike Hughes For This Useful Post:
midwinter (15-Sep-2017)
  #3  
Old 15-Sep-2017, 09:22 AM
midwinter midwinter is offline
Registered User
Join Date: Jan 2010
Full Name: Ian Alcock
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Talking

Mike,
Thank you so much!
I vaguely remembered a hugely long secret ID from years ago, and didn't consider trying all of the simple numbers and letters I had.
I must admit I'd been lpaying attention to more recent posts without considering 2005
Not quite tweaked it completely yet, but got as far as the worldpay payment page, so all in hand!!
Thanks again
Ian
Reply With Quote
  #4  
Old 16-Sep-2017, 04:00 PM
midwinter midwinter is offline
Registered User
Join Date: Jan 2010
Full Name: Ian Alcock
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Anyone using Worldpay (I can't integrate)

Hi again,

I was prematurely delighted

Unfortunately the worldpay page I havebeen able to reach repeatedly is only this one !!
Secure Payment Page
Sorry, there was a problem processing your payment:
The information sent from the merchant's site is invalid or incomplete. Please send the following information to the merchant:

The transaction cannot be processed for one or more of the following reasons:

The installation ID field is blank or contains invalid characters.
A different submission protocol is required. A more secure submission may be required.
The installation number is invalid.


I have the following:
Installation ID (7 digit number)
MID - assume this is merchant ID, (it just says MID) (8 digfit number)
Admin code Capital letters MYCOMPANYNAME
Merchant Code Capital letters MYCOMPANYNAMEM1

And the following boxes in sellerdeck to configure for worldpay:
Merchant ID
Secret Key
Confirm Key

I'm pretty sure I've tried every combination of these two with the same result (top of page)

The tel support person at worldpay had no idea what I was talking about, and I'm still waiting for an email response from worldpay (now day 4).

I'm just wondering if anyone knows if I'm actually missing a number somewhere or am I not entering things correctly?

Grateful for any help,
Ian
Reply With Quote
  #5  
Old 11-Oct-2017, 10:27 PM
HD Direct HD Direct is offline
Registered User
Join Date: Apr 2005
Full Name: Andy
Posts: 57
Thanks: 13
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by midwinter View Post
Hi again,

I was prematurely delighted

Unfortunately the worldpay page I havebeen able to reach repeatedly is only this one !!
Secure Payment Page
Sorry, there was a problem processing your payment:
The information sent from the merchant's site is invalid or incomplete. Please send the following information to the merchant:

The transaction cannot be processed for one or more of the following reasons:

The installation ID field is blank or contains invalid characters.
A different submission protocol is required. A more secure submission may be required.
The installation number is invalid.


I have the following:
Installation ID (7 digit number)
MID - assume this is merchant ID, (it just says MID) (8 digfit number)
Admin code Capital letters MYCOMPANYNAME
Merchant Code Capital letters MYCOMPANYNAMEM1

And the following boxes in sellerdeck to configure for worldpay:
Merchant ID
Secret Key
Confirm Key

I'm pretty sure I've tried every combination of these two with the same result (top of page)

The tel support person at worldpay had no idea what I was talking about, and I'm still waiting for an email response from worldpay (now day 4).

I'm just wondering if anyone knows if I'm actually missing a number somewhere or am I not entering things correctly?

Grateful for any help,
Ian
A bit late to the party but my secret key was in one of the emails they send when you open the account. (mind you it isn't very prominent)
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 09:55 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.