My SellerDeck Account | Newsletter | Free Trial

Community and Knowledge Base

Go Back   Sellerdeck Community > Discussion Areas > Bug Reports

Search powered by Google
Register FAQ Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Useful Thread? Display Modes
  #1  
Old 03-Sep-2016, 10:24 AM
NormanRouxel's Avatar
NormanRouxel NormanRouxel is offline
Registered User
Join Date: Dec 2002
Full Name: Norman Rouxel
Posts: 10,746
Thanks: 9
Thanked 732 Times in 616 Posts
The CatalogURL variable is always returning http://

The CatalogURL variable is always returning http://.... even when the whole site is set to use https.

Example:

In Settings / Business Settings / Payment and Security / Payment Security, check Use SSL and Whole Site. Check the Network Setup to be sure https:// is ised throughout.

Now refresh the site and look in the generated sitemap.xml and you'll see a messy mix of https:// and http://

See http://community.sellerdeck.com/showthread.php?t=56965 for an example of an affected user and a workaround or two.
__________________
Norman - www.drillpine.biz
Edinburgh, U K / Bitez, Turkey
Reply With Quote
  #2  
Old 09-Sep-2016, 05:01 PM
DaveSMR DaveSMR is offline
Registered User
Join Date: Aug 2010
Full Name: David Tolman
Posts: 86
Thanks: 13
Thanked 3 Times in 3 Posts
Hi Norman,

I found this too.

I also found SSLCatalogURL which of course gives the right response but demands that conditions be wrapped around both variables to return the correct value.

Would be better if CatalogURL just returned the correct value compared to setup.
__________________
Dave
Reply With Quote
  #3  
Old 26-Oct-2016, 08:15 AM
brucet brucet is offline
Administrator
Join Date: Apr 2003
Full Name: Bruce Townsend
Posts: 944
Thanks: 55
Thanked 224 Times in 134 Posts
This issue is resolved in v16.0.2, available now from www.sellerdeck.co.uk/index.php/support/category/ecommerce-software
__________________
Bruce Townsend
Ecommerce Product Manager
SellerDeck Ecommerce Solutions
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 03:30 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.