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PRICE INCREASE USING HIERARCHICAL FILE
--------------------------------------
--------------------------------------

Perform a backup (site snapshot & database) before you start, because if your import goes wrong(which 
can easily happen) it could alter your site dramatically and you will need to re-import the site backup 
snapshot to be able to get back to where you were before you started.

--------------------------------------------------------------------------------
EXPORT A HIERARCHICAL FILE FROM ACTINIC

To export a hierarchical file in Excel.csv format, open Actinic and in the top tool bar select 
File>Export... 

The Export Wizard dialogue box will display.

>select, Next

>select, Catalog

>select, Next

The Export File dialogue box displays

>In the File Name: text box enter PriceMaster.csv

>Select browse

The Save As dialogue box will display

>File name: will be PriceMaster

>Save as type: will be Data files(*.csv,*.dat,.*txt)

>selectthe Desktop Icon on the left hand toolbar

>select, save

The Export File dialogue box displays

>File Name: will be C:\Documents and Settings\YOUR NAME OR OTHER TEXT\Desktop
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\PriceMaster.csv

>In What type of file do you want to export?, select Text - Comma Delimited

>In what character set do you wish to use to create the file?, select ANSI(Windows)

>select, Finish 

The Export progress dialogue box will display the following:

>Preparing export... should be displayed with a tick

>Exporting... should be displayed with a tick

>Export complete. should be displayed

>select, OK

--------------------------------------------------------------------------------
FIND THE PriceMaster FILE

View your Desktop screen and the Excel file PriceMaster.csv should now be there 

--------------------------------------------------------------------------------

OPEN THE PriceMaster FILE

>Left click the  PriceMaster.csv file to select and open it.

A table called PriceMaster will display and on it you will see the hierarchical format of all your site 
information.

Count the number of rows of text by scrolling down the left hand side of the table to the bottom row of 
text(record forlateruse).
 
--------------------------------------------------------------------------------
DELETE PRODUCT FRAGMENTS

If you have used Brochure Fragments in your site(and other text areas), you will see(if you look at any 
line named Brochure Fragment...normally in Column A) and look at the text in Column E, that Actinic 
has inserted \n in to your text wherever you inserted a carraige return in your site. The \n imports back 
correctly from brochure fragments and elsewhere, but not from Product Fragments that were created in 
your Catalogue (so they will be visible when you re-import the file, if you do not alter or delete). 
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You can either edit the fragment and remove the \n and substitute with <br>, which if you have 
constructed long brochure fragment is a huge task or you can delete them(the simplest option).

To delete, scroll to Column BB(underneath it you will see that row 2 is headed Fragment text). Left 
click BB and the column will be Highlighted, right click and select delete from the menu.

All Your Product Fragment text is now deleted in Column BB . 

You should note that due to deleting the product fragments you will get an error report(a .txt file) when 
you eventually re-import new prices back in to Actinic. Just go to the line (row) that the report states and 
confirm that the import was oK(your fragment text should not have changed in your site as there was no 
text to import as it was all deleted). 
 
--------------------------------------------------------------------------------
INSERT A NUMERICALLY ORDERED COLUMN

A column needs to be added to enable reverse sorting of the table data once product prices have been 
changed.

Now scroll to Column A. Left click A and the column will be Highlighted, right click and select insert 
from the menu.

A new column A will be inserted.

>select the cell in Row 1, Column A and enter the number 1

>select another cell(which can be any where close to the above cell).You do this otherwise the Series 
function does not operate when you use it later.

>select the cell in Row 1, Column A again. 

>In the top tool bar select Edit>Fill>Series..  

The Series dialogue box will display

>In Series in, select, Columns

>In Type:, select, Linear

>In step value:,insert 1

>In stop value:, insert the total number of rows of text in the table(if you have not done so already,scroll 
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down to the left hand bottom side of the table to see last text row number.

>select, OK

You should now see numbers in Column A that duplicate the table row numbers. These new numbers 
will be used to ensure that you can come back to the original format of the table after you have sorted 
the columns.

--------------------------------------------------------------------------------
INSERT AN EMPTY COLUMN FOR PRICE CHANGES

Now scroll to Column H. Left click H and the column will be Highlighted, right click and select insert 
from the menu.

This inserts a new empty column H next to column G. Column G has all the cells in it that hold your 
current product prices. The new column H will be used to produce new prices(which will then be 
transposed in to column G).

--------------------------------------------------------------------------------
SORT TABLE INTO ALPHABETICAL ORDER

Now scroll to the top left corner of the table (where Row 1 meets with Column A). Left click the corner
(a grey rectangular area) of the table to highlight the complete table. 

>In the top tool bar select Data>Sort...

The Sort dialogue box displays

>In Sort by, select Column B in the drop down text box and select Ascending

>Leave the Then by drop down text boxes blank and as Ascending

>In My data range has, select No header row

>select, OK

Column B (and entire table comtents) will now be sorted into alphabetical order(Perform a random 
check to ensure that the data in the rows is correct, if not start again from scratch).
 
--------------------------------------------------------------------------------
SORT PRODUCTS INTO A CONTINUOUS LIST

To sort the products into a continous list
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>Left click Column B, which will highlight the entire column 

>In the top tool bar select Data>Filter>Autofilter

You will see a text box appear(with side arrow) in Row 1, Column B  

>select text box arrow and scroll down the list that appears to the word Product.

>Select Product

The list should now display only products(apart from Row 1 which should be an attribute). And the 
products should be in the order that you entered them in you catalogue.

Products which do not have prices and/or only have have Product Fragments will also be on the list(in 
the row that they are in you may see a single digit in Column C and/or a 0 in Column G).Treat these as 
normal products as they will re-import, but  possibly with an error message(if their text has been 
removed from Column BB previously). 

--------------------------------------------------------------------------------
CHANGE PRODUCT PRICES

Place your cursor in the first cell of Column H that lines up with the first word Product in Column B 
(which should be in the first row under Row 1). 

>enter the following formula... =abs(cell*factor), where cell = the price you want to change(which 
should be in Column G) and factor = the factor you want to use to change the price e.g. if you wanted to 
increase the price of a product contained in cell G500 by 50% use =abs(G500*2), if you wanted to 
decrease the price by 50% use =abs(G500/2), if you wanted to increase the price by a 50% margin use 
=abs(G500/.5)and if you wanted to reduce the price by a 50% margin use =abs(G500*.5)

You can use any formula that suits your purpose (if you wish to increase, decrease, or add a margin or 
markup).

If you want a global price change, the formula can the be copied to the rest of the products in column H 
by dragging. 

>left click formula cell, release and move cursor into bottom right hand corner of cell until black plus 
sign appears and drag down column to end of product list.

If you want to change price by section, it will be slower as you will need to alter the formula for each if 
the price change is different for each section(you will need to know when the sections start and finish).
--------------------------------------------------------------------------------
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MOVE CHANGED PRODUCTS TO CORRECT COLUMN

Once you have the new prices in Column H you will need to transpose them into Column G.

>Place your cursor in the first cell of Column H that lines up with the first word Product in Column B
(should be on the first row under Row 1). To copy drag cursor down  Column B  to the last line of you 
Products(The column should be highlighted). Right click and select copy from the menu(A dashed line 
will appear arround the cells that are to be copied).

>Place your cursor in the first cell of Column G that lines up with the first word Product in Column B. 
Right click and select paste special from the menu.
 
The Paste Special dialogue will display

>In Paste... select Values (The formula are not transposed).

>In Operation...select None

>select, OK

The new prices are transposed into Column G

--------------------------------------------------------------------------------
REMOVE DECIMAL POINTS

If your new product prices in column G have decimal points, the points must be removed as Actinic 
cannot import them.

>Place your cursor in the first cell of Column G that lines up with the first word Product in Column B
(should be on the first row under Row 1).Left click, hold and drag cursor down  Column G  to the last 
line of you Products(The column should be now be highlighted). 

>Right click and select Format Cells from the menu that appears

>select Number

>In Decimal places, select 0 in text box(using side arrows)

>select, OK

The product prices should now display without decimal points. They will also be rounded down to the 
nearest whole number.
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--------------------------------------------------------------------------------
UNSORT CONTINUOUS LIST

The Autofilter now has to be removed

>Left click Column B, which will highlight the entire column 

>In the top tool bar select Data>Filter>Autofilter

Autofilter is removed

--------------------------------------------------------------------------------
SORT TABLE BACK TO ORIGINAL ORDER

Now you need to get the table back to its original order. 

Now scroll to the top left of the table(where Row 1 meets with Column A). Left click the corner(the 
grey rectangular area) to highlight the complete table. 

>In the top tool bar select Data>Sort...

The Sort dialogue box displays

>In Sort by, select Column A in the drop down text box and select Ascending

>Leave the Then by drop down text boxes blank and as Ascending

>In My data range has, select No header row

>select, OK

--------------------------------------------------------------------------------
DELETE COLUMN H

Now scroll to Column H. 

>Left click H and the column will be Highlighted, right click and select delete from the down menu.

This removes the column where the prices were changed. 

--------------------------------------------------------------------------------  
DELETE COLUMN A
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Now scroll to Column A. 

>Left click A and the column will be Highlighted, right click and select delete from the down menu.

This removes the numbered column

The hierarchical file is now back to how it was when you exported it, but with your newly changed 
prices. 

--------------------------------------------------------------------------------
EXIT EXCEL AND SAVE THE FILE

>Select the Red Box with the White X in it to exit Excel(top right hand corner of screen)

The Microsoft Excel dialogue box appears

>After, Do you want to save the changes you made to 'PriceMaster.csv', select Yes

The Save As dialogue box appears

>select the Desktop Icon on the left hand toolbar

>In the File Name: text box enter PriceMaster1

>Save as type= CSV(Comma delimited)

>select, save

The Microsoft Excel dialogue box displays

>After PriceMaster1.csv may contain features that are not compatible with CSV(Comma delimited).Do 
you want to keep the workbook in this format, select Yes 
        
You should now be back to the Desk Top and you should see a new file PriceMaster1.csv. You must 
import this file into Actinic as it contains all your price changes in it. The file PriceMaster.csv should be 
kept as a master copy so that you can start again from scratch if necessary(as it does not contain 
changes).

--------------------------------------------------------------------------------
IMPORT THE HIERARCHICAL FILE TO ACTINIC

To import a hierarchical file in Excel CSV format, open Actinic and select File>Import...
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The Import Wizard dialogue box will display.

>In Import Type:, select Hierarchical Import

>select, Next

The File to import dialogue box displays

>select, browse

The Select... dialogue box will display

>select the Desktop Icon on the lefthand toolbar

>select PriceMaster1 from the list displayed

File name: will be PriceMaster1

Save as type: will be Data files(*.csv,*dat,.*txt)

>select, open

The File to import dialogue box displays

>After, Do you wish to replace or update your existing data?, select Update

>After, What type of file do you want to export? select Text - Comma Delimited

>After, What character set do you wish to use to create the file? select ANSI(Windows)

>Does the first record contain field names(in which case it will not be imported)?, will be Yes (and is 
automatically selected for you).

>select, Next 

The Map fields for Section table(Catalog sections) dialogue box will display. 

>The import field should be pre-ticked for all fields

>select, Next

The Map fields for Product table (Products) dialogue box will display.
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>The import field should be pre-ticked for all fields(although the froogle and thumbnail may not be).

>select, Next

The Map fields for Section table (Catalog sections) dialogue box will display.

>The import field should be pre-ticked for all fields

>select, Next

The Map fields for Attribute table (Attributes) dialogue box will display.

>The import field should be pre-ticked for all fields

>select, Next

The Map fields for Choice table (Choices) dialogue box will display.

>The import field should be pre-ticked for all fields

>select, Next

The Map fields for Price table (Prices) dialogue box will display.

>The import field should be pre-ticked for all fields

>select, Next

The Map fields for CustomProperties table(Catalog custom properties) dialogue box will display.

>The import field should be pre-ticked for all fields

>select, Next

The Map fields for ValidCustom Property table (Defined custom prope...) dialogue box will display.

>The import field should be pre-ticked for all fields

>select next

The Map fields for PriceSchedule  table (Price schedules) dialogue box will display.

>The import field should be pre-ticked for all fields
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>select, next

The Map fields for BrochurePage table (Web Page) dialogue box will display.

>The import field should be pre-ticked for all fields

>select next

The Map fields for BrochureFragment table (Web Page Fragment) dialogue box will display.

>The import field should be pre-ticked for all fields

>select, next

The Error reporting dialogue box will display.

>select... Make a List of Lines that Fail to Import (If import fails you will need to go to this to find out 
why and which lines failed)

>Save List in a file: should read C:\Documents and Settings\YOUR NAME OR SOMETHING\Desktop
\Mistakes.txt(You can select browse and save .txt file to a different place if you wish)

>select, Finish

The Business dialogue box will display.

>Read the contents of the scrolling text box and if everything is OK select, Yes

The import will commence.

The Importing new Catalog dialogue box will display and run automatically

>Preparing import.. should be automatically ticked

>Importing all records into Actinic.. should be automatically ticked

>Consolidating imported records.. should be automatically ticked

>Closing import..should be automatically ticked.

>Complete should display
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>Select, OK

If errors are found the Business dialogue box will display with the the message... Atleast one error 
occured during import. Do you wish to view the error file...select, Yes

The Mistakes.txt will display, view and print a copy.

Resolve errors(If there are too many the import may fail). If you have removed Product fragments you 
will get an error message. Check the lines(Rows) shown as errors on the Mistakes.txt file against the 
lines(Rows) on the table of PriceMaster1.csv and you should find that the errors are related to product 
fragment text that you have removed.You will find that the error is always on the line(row) above that 
stated e.g an error stated for Line 40  is actually in Line 41. 

There are many reasons why you may get errors(so I will not go into them here),some may be simple to 
understand and resolve and others may take more time to identify.The errors may not be as a result of 
the changes you have made to the file, but due to mistakes made when building your site and you may 
need to resolve these before the file imports correctly(as it will recognise build errors when it re-imports 
the hierarchical file and the import may fail). You may also get errors if the brochure fragments are too 
long as there is a maximum capacity for an Excel cell and although Actinic will export the fragment it 
does not want to re-import.

--------------------------------------------------------------------------------
IMPORT PROCESS COMPLETED

If there are no errors(apart from the product fragment errors that you should expect to get if you have 
removed product fragment text), your re-import should have been completed successfully.

Open Actinic and check that the product prices have been updated.

Complete a random check to ensure that your site has not altered, apart from those planned to the 
product prices.

If there are unplanned changes or unresolved errors you may wish to consider re-importing your original 
snapshot backup and starting again. Once the errors are resolved You will have to complete all the above 
again.

--------------------------------------------------------------------------------
DISCLAIMER

The above guidance is offered and used under the undestanding that the author accepts no responsibility 
for any loss whatsoever suffered as a result of its use by the user.
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Should you find mistakes or an easier route to acheive the above, please email details to rob.
lane@databond.co.uk(Known as DATARAX in the Actinic Community).
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