Announcement

Collapse

Sellerdeck Community upgrade

18 May: completed upgrade of the Sellerdeck Community software. Please report any issues in this post.
See more
See less

Faulty Condition if [LINK] used in Product Description

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Faulty Condition if [LINK] used in Product Description

    SellerDeck 2014 has a BlockIf around the product description. E.g:
    Code:
    <actinic:block if="%3cactinic%3avariable%20name%3d%22ProductDescription%22%20%2f%3e%20%21%3d%20%22%22"><div class="product-text"><actinic:variable name="ProductDescription" /></div></actinic:block>
    Essentally, if Product Description not empty, then output <div class="product-text">Description</div>.

    This condition fails if the Advanced Link capability is used. And no description appears.

    I.e. Demo Site / Solitaire Diamond Ring.
    Go to Design tab.
    Amend description to be:

    3ct solitaire [LINK]diamond ring.
    Available in both yellow gold and white gold.
    .
    Error appears (if it doesn't) go to the Links tab and fill in an Advanced Link.

    Weirdly it seems to be sensitive to the actual text used. E.g. in the Solitaire Diamond Ring, product:

    3ct solitaire [LINK] diamond ring.
    Available in both yellow gold and white gold.

    Is OK

    But:
    3ct solitaire [LINK] diamond ring.
    Available in both yellow gold and white gold.

    Also fails (2 spaces after the [LINK].

    UPDATE: This is even weirder than I first thought. I tried this on another site with the following text:

    3ct solitaire[LINK]diamond ring.
    Available in both yellow gold and white gold.

    And the error doesn't appear. Now if I change the text to be:

    A 3ct solitaire[LINK]diamond ring.
    Available in both yellow gold and white gold.

    The error re-appears even though all I've done is add one letter to the start of the sentence. I've changed nothing around the [LINK] area but now get an error.
    Norman - www.drillpine.biz
    Edinburgh, U K / Bitez, Turkey

  • #2
    Please contact SellerDeck Support

    Hello Norman,

    Would you mind contacting me in support regarding this issue? PM or direct email is fine.

    Regards,
    Dean James
    Technical Support - SellerDeck
    http://www.sellerdeck.co.uk/

    Further help can also be found at http://community.sellerdeck.com/forumdisplay.php?f=27

    Comment


    • #3
      Hi Dean,
      Was this issue ever rectified as i am also experiencing the similar bug whilst developing the site for a client? I can't see any bug fixes within the 14.0.02 release notes.
      Regards.

      Lee Jackson
      Creative Director

      Centurius Design & Marketing
      Centurius Website
      Portfolio of Work

      Comment


      • #4
        Hello Lee,

        Please PM me I would like to obtain a copy of the site you are working on. However is appears this may have been resolved in 14.0.1 as

        "Using square brackets in a product full description misbehaves, breaks product links in search/filtering"
        SD-4715 (Panned for next release).

        Checking this further.

        [EDIT]

        ON further analysis the bug referred to on this post was resolved in 14.0.1 under:

        SD-4712

        Currently the workaround is to delete the condition opening 'block if' and closing '/block' statements around the "ProductDescription" variable;

        I.E. replace:

        Code:
        <actinic:block if="%3cactinic%3avariable%20name%3d%22ProductDescription%22%20%2f%3e%20%21%3d%20%22%22" ><div class="product-text"><actinic:variable name="ProductDescription" /></div></actinic:block>
        with

        Code:
        <div class="product-text"><actinic:variable name="ProductDescription" /></div>
        Regards,
        Dean James
        Technical Support - SellerDeck
        http://www.sellerdeck.co.uk/

        Further help can also be found at http://community.sellerdeck.com/forumdisplay.php?f=27

        Comment


        • #5
          Hi Dean,
          Thanks for the additional information. Unfortunately I would like the block statements around the Product description as my client has not entered Product Description content for all his product therefore his page will have a title 'Description' and then nothing underneath.

          Has the issue with square brackets within the content been addressed if the block tage are placed around the Product Description variable?

          I look forward to hearing form you.
          Regards.

          Lee Jackson
          Creative Director

          Centurius Design & Marketing
          Centurius Website
          Portfolio of Work

          Comment


          • #6
            Hello Lee,

            Yes the coding error was resolved in 14.0.1 under bug reference SD-4712
            Dean James
            Technical Support - SellerDeck
            http://www.sellerdeck.co.uk/

            Further help can also be found at http://community.sellerdeck.com/forumdisplay.php?f=27

            Comment

            Working...
            X