I can't see the product 'Maximum' and 'Minimum' Quantity fields on my product details panel.

The 'Maximum Quantity' and 'Minimum Quantity' fields on the product 'details' panel will be hidden if you have the 'Order Quantity Always One' field ticked in 'Settings | Business Settings | Ordering' panel. If you un-tick this option and click OK, you may need to move to a different product in the content tree to see the fields re-appear.