Announcement

Collapse

Sellerdeck Community upgrade

18 May: completed upgrade of the Sellerdeck Community software. Please report any issues in this post.
See more
See less

I am getting duplicate orders and customers are not receiving emails.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I am getting duplicate orders and customers are not receiving emails.

    If you are using 1and1 as your hosting service and you are finding that: -
    • You are receiving duplicate orders
    • You and your customers have stopped receiving receipt emails
    • The checkout freezes after clicking the 'Confirm Order' button

    These are all symptoms of the same problem.
    Once the 'Confirm Order' is pressed the SMTP (email) server is contacted, however currently customers of 1and1 are seeing extreme delays in contacting the SMTP server (can be up to one minute).

    This can cause some customers to click the confirm button multiple times (giving duplicate orders) or clicking away to another site meaning that the receipt email will not be sent (the emails are only triggered when the receipt page is displayed).

    If the page is left it will eventually transfer to the receipt page and the emails will be sent.

    SellerDeck are aware of the problem and it will be addressed in due course. 1and1 have been sent SellerDeck mail scripts and both 1and1 and SellerDeck development are looking into this.

    It is possible to temporarily prevent duplicate orders from occuring by going to 'Settings | Business Settings | Ordering' and removing the tick from 'Send Receipt Email to Customer' and removing everything within the 'Send Receipt Email Copies to' field, clicking 'OK' and uploading the site.

    Please Note: This will however stop all receipt emails being sent to the customer and any copies to the site vendor.

  • #2
    The solution to this problem is to change the name of your SMTP server (on the server itself where your site is hosted)

    On Windows servers, within say IIS6, if defaults to naming the SMTP server LOCALHOST - change this to www.yourdomainname.co.uk (substitute your 'real' domain name)

    (Note: we also run IIS7 on our server, for hosting our websites, but it is not possible to change the SMTP server name in there - that is why we also run IIS6)

    Here is a post showing how to change the setting:

    https://www.microsoft.com/technet/pr....mspx?mfr=true

    Note: This is the name of the [actual] SMTP server on your Windows/Unix WebServer (not within Sellerdeck/Actinic - leave it set in SD as LOCALHOST (if that's what you have set))

    On Unix/Linux servers I don't know where/how you would check it/set it but I suspect it is the same problem/solution... just need to locate where the SMTP server is named...

    Hope this helps...

    Bill.

    27/02/2014 Addendum: This solution is for 'Dedicated Servers' - it appears that websites hosted on 'shared servers' may have a different solution.
    Bill

    HTML Code:
    <a href="www.spicesofindia.co.uk">www.spicesofindia.co.uk</a>

    Comment

    Working...
    X