Announcement

Collapse

Sellerdeck Community upgrade

18 May: completed upgrade of the Sellerdeck Community software. Please report any issues in this post.
See more
See less

1&1 no longer support 32 bit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1&1 no longer support 32 bit

    Just received an email from 1&1 informing me that since their server upgrades, they are no longer supporting 32bit. This just came through today (24th June)
    I am running Actinic Business Pro 10.0.2 KIIA
    Since this server upgrade, orders placed paying with PayPal, go to Paypal where payment is taken, but fail to return order after the confirm page is shown (and result in 'server error'), so we have payment but no order details downloaded
    Orders placed via Sellerdeck Payments don't even reach the payments page, and just give 'server error' when you press 'confirm' order
    Is it a case of version 10.0.2 is 32 bit and more up to date Sellerdeck runs 64 bit, and if so, what is my best upgrade path?
    If this is not the case, any idea what the problem is?

  • #2
    This was discussed here: http://community.sellerdeck.com/showthread.php?t=56801

    The conclusion seemed to be that 32 bit support wasn't going to be the problem as the scripts run under the perl interpreter and that's what needs to be 64 bit, not the perl scripts themselves.

    What could be a problem is the version of perl that is running and this might have been changed with the upgrade.

    My own site on 1and1 seems to be OK and is handing over to secpay and paypal OK. I tested it this morning, and someone else tested it last night (?).

    This might just be that the server I'm on hasn't been upgraded yet but I don't know either way.

    There was also some discussion not too long ago about setting the PHP version on 1and1 could fix a problem that arose. Why this works doesn't really make sense to me as the scripts use perl, not php, but you might want to look into that as well.
    -----------------------------------------

    First Tackle - Fly Fishing and Game Angling

    -----------------------------------------

    Comment


    • #3
      Hi Mike
      Thank you for the info.
      I do not tend to be around on the boards much these days, but should have searched better
      I am going to give that PHP setting advice a go if it will let me

      Your phantom test order last night was me I'm afraid - sorry, I should have asked you first!
      At least it is good to see that you are up and running whilst some of us other1&1'ers are having issues
      Martin

      Comment


      • #4
        I have gone into the 1&1 dashboard to see if I can change PHP version as per instructions, but cannot see anywhere that this can be done.

        Does this maybe only apply to dedicated servers, or should I be able to change my PHOP on my shared server?

        If so, where I am supposed to be looking?

        Comment


        • #5
          SellerDeck does not use PHP on your server so that may be a red-herring.
          Norman - www.drillpine.biz
          Edinburgh, U K / Bitez, Turkey

          Comment


          • #6
            If you look in 'Web hosting Overview' => 'PHP settings' you can set the php version there for each domain.

            As I said earlier, it's weird that it can make a difference but all I can suggest is that there might be something else happening that's related.
            -----------------------------------------

            First Tackle - Fly Fishing and Game Angling

            -----------------------------------------

            Comment


            • #7
              You should be able to check what perl version is running via the help menu in sellerdeck (I think it's available in 10.0.2). Some versions of perl have been known to cause problems in the past.

              Go To Help> Troubleshooting > and click 'Web site analysis' in sellrdeck/Actinic and this will take you to a browser page that will show you the perl version running on the server (amongst other things).

              It does take a while to load so be patient.

              Mike
              -----------------------------------------

              First Tackle - Fly Fishing and Game Angling

              -----------------------------------------

              Comment


              • #8
                Thanks Mike and Norman
                Had to head out soon after posting, so only just looking at this now
                Have set PHP to lowest available which was 5.4
                Will have a look at what Perl is running in a mo

                Comment


                • #9
                  Now having set PHP to 5.4 (it was unallocated before) on 1&1 and republished website - no change - still failing.

                  I take on board what Norman said, although my understanding of Perl, PHP etc is zero

                  So the facts I have available:

                  Email from 1&1 about server upgrade states the following

                  The moment has arrived: We have successfully performed the upgrade for you.
                  Since we no longer support 32 bit applications, please check to ensure
                  that your scripts are functioning properly. As of now, the following
                  scripting language versions and database library versions are available to
                  you:

                  - Perl 5.20
                  - Python 2.70 and 3.4
                  - Ruby 2.1
                  - Berkeley DB 5.3
                  My Sellerdeck version is using Perl 5.02.0002 (and I am using software 10.0.2)

                  The page fails (where I get Internal server Error 500) at
                  www.megacitycomics.co.uk/cgi-bin/os000002.pl

                  (does the .pl extension have anything to do with perl?)

                  SSL is unchecked (and has been for as long as I can remember, as payments go via SD payments or PayPal)

                  Haven't tried a ful Purge & refresh yet, in case that is something I should be doing. In fact it is so long since I have done a Purge & Refresh (I am sure that is what it used to be called), that I cannot even find that option on SD at first glance (I am sure its tucked away somewhere)


                  Any help appreciated

                  Comment


                  • #10
                    Under troubleshooting
                    Chris Ashdown

                    Comment


                    • #11
                      I suspect it's the perl version that might be the problem. From what I can tell, Perl 5.02.0002 refers to version 5.20 release 2

                      There are other reports of version 5.20 causing issues at the checkout. I haven't seen any solution and at least one person who reported it went back to perl 5.10 to get it working again

                      When I checked last week my 1and1 server was still on perl 5.10 which I use as an indication that the server hasn't been updated yet.

                      If it is a problem with perl 5.20 then sellerdeck need to get involved in finding the problem and a solution as there are a lot of us using 1and1 and the server requirements they specify are "perl 5.04 or better" (whatever better means).

                      Have you reported the problem to sellerdeck?
                      -----------------------------------------

                      First Tackle - Fly Fishing and Game Angling

                      -----------------------------------------

                      Comment


                      • #12
                        Thanks Chris.
                        Thanks Mike.
                        As I am on a shared server, can I influence what version of Perl is used?
                        Isn't this something that 1&1 upgrade, or is there some way I can fix the version, like I did with PHP following forum advice?
                        Whilst I am using an older version of SD (10) I do still pay around 1000 a year for support (I do ask myself why), so yes, I reiterate what Mike says in that, if this is something that is happening because of an outdated version of Perl, could Sellerdeck please take whatever action is needed to fix this. 1&1 users are plentiful, so this is going to affect more and more of us as the 1&1 server upgrade rolls out.
                        If I upgrade SD to a newer version, any idea if this will resolve it, and if so, what is my best upgrade path from 10.0.02? I am still bearing in mind what Norman said about SD no longer using Perl, so admit again to not understanding any of this

                        Comment


                        • #13
                          Norman said about SD no longer using Perl
                          It's PHP that SellerDeck doesn't use. It's Perl that is essential for SD to operate.
                          Norman - www.drillpine.biz
                          Edinburgh, U K / Bitez, Turkey

                          Comment


                          • #14
                            Sorry for mis-quoting you Norman
                            I should have checked
                            I don't really understand all this PHP and Perl stuff - I just want my website back taking orders again!
                            Mike, do you know if I can change the Perl used on my shared 1&1 server?

                            Comment


                            • #15
                              I don't think you can change the perl version on a 1&1 shared server. Best call them to confirm.

                              To get sellerdeck support you need to call them and get them to investigate the problem. Posting on the forum is not sufficient.

                              If sellerdeck can't provide a quick solution then one option is to get another web host as a temporary solution. Web hosting is very cheap and if you have your domain name with someone like 123reg it only takes a few minutes to point your domain to another web server.
                              -----------------------------------------

                              First Tackle - Fly Fishing and Game Angling

                              -----------------------------------------

                              Comment

                              Working...
                              X