Announcement

Collapse
No announcement yet.

Unable to remove https

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to remove https

    Hi,
    I set the Option in Business Settings|Payment & Security to Use SSL/ Whole Site.

    This was fine with our live site that has a certificate but forgot about our Dev site dev.sheltonsfishing.co.uk that is not encompassed by the certificate. So I took the setting off for while I was developing, but while browsing the dev I am getting errors because it is still trying to use https even after disabling it.

    I have used FireFox Developer tools and can see that Sellerdeck is still adding the https to image links and there's also this line which I cannot see when in SellerDeck Design:
    Code:
    <actinic:basehref value="https://dev.sheltonsfishing.co.uk/" forced="1">
    How can I undo the https? Must be a way?

    John.
    John
    Sheltons Fishing Tackle
    www.sheltonsfishing.co.uk
    sigpic

  • #2
    Look in Web / Network Setup.
    Norman - www.drillpine.biz
    Edinburgh, U K / Bitez, Turkey

    Comment


    • #3
      Originally posted by NormanRouxel View Post
      Look in Web / Network Setup.
      Hi Norman, I have and all set to http - forgot to mention in my original post. Also did the Web Refresh Option.

      John
      John
      Sheltons Fishing Tackle
      www.sheltonsfishing.co.uk
      sigpic

      Comment


      • #4
        Hmmm... Weirdly, it seems to only be your home page that's doing this. All other pages have http:// links in them.

        Are you using a different overall layout for the home page?
        Norman - www.drillpine.biz
        Edinburgh, U K / Bitez, Turkey

        Comment


        • #5
          Originally posted by NormanRouxel View Post
          Hmmm... Weirdly, it seems to only be your home page that's doing this. All other pages have http:// links in them.

          Are you using a different overall layout for the home page?
          Hi Norman,
          Not as far as I am aware. How would I check this?

          There is a layout.html in the Site1 and it is this that appears to be the home page.

          John.
          John
          Sheltons Fishing Tackle
          www.sheltonsfishing.co.uk
          sigpic

          Comment


          • #6
            You haven't got https set in your website url setting have you?
            -----------------------------------------

            First Tackle - Fly Fishing and Game Angling

            -----------------------------------------

            Comment


            • #7
              Originally posted by Mike Hughes View Post
              You haven't got https set in your website url setting have you?
              If your referring to Network Settings, that has been covered, if not can you clarify what you mean please.

              John.
              John
              Sheltons Fishing Tackle
              www.sheltonsfishing.co.uk
              sigpic

              Comment


              • #8
                Originally posted by Sheltons View Post
                If your referring to Network Settings, that has been covered, if not can you clarify what you mean please.

                John.
                Just to clarify the Network Settings i have for dev are:
                John
                Sheltons Fishing Tackle
                www.sheltonsfishing.co.uk
                sigpic

                Comment


                • #9
                  Check that the home page isn't an obsolete one. Try changing something that appears on the home page (a bit of text perhaps). Do an Update and see if that change is visible online.
                  Norman - www.drillpine.biz
                  Edinburgh, U K / Bitez, Turkey

                  Comment


                  • #10
                    Originally posted by NormanRouxel View Post
                    Check that the home page isn't an obsolete one. Try changing something that appears on the home page (a bit of text perhaps). Do an Update and see if that change is visible online.
                    Hi Norman - Do you ever sleep! lol

                    Ok, that was obvious really - Feel a little embarrassed!

                    I added "This is a Test" in design mode and have uploaded - I can see it on the site.

                    Looked in to adding SSL to the Subdomains but 1and1 want me to pay an additional 23.99 per month for the privilege and our Share Hosting does not allow for the use of 3rd Party (GoDaddy) Certificates.

                    Thanks
                    John.
                    John
                    Sheltons Fishing Tackle
                    www.sheltonsfishing.co.uk
                    sigpic

                    Comment


                    • #11
                      If your referring to Network Settings, that has been covered, if not can you clarify what you mean please.
                      Sorry if I wasn't clear. The Web site URL is set separately from the rest of the SSL setiings and I was just suggesting nit might have been overlooked.

                      I can see from the settings you've posted that this isn't the case.

                      You might need to clear / erase all the SSL settings.

                      If you go to Settings > Business Settings > Payment and security, tick the 'Use SSL' and the 'Checkout, Login and Accounts pages only' then the configure SSL button will show you the separate SSL tab so you can delete any settings in there just in case they're interfering.

                      Mike

                      Edit: I see it's now solved. Great.
                      -----------------------------------------

                      First Tackle - Fly Fishing and Game Angling

                      -----------------------------------------

                      Comment


                      • #12
                        Originally posted by Mike Hughes View Post
                        Sorry if I wasn't clear. The Web site URL is set separately from the rest of the SSL setiings and I was just suggesting nit might have been overlooked.

                        I can see from the settings you've posted that this isn't the case.

                        You might need to clear / erase all the SSL settings.

                        If you go to Settings > Business Settings > Payment and security, tick the 'Use SSL' and the 'Checkout, Login and Accounts pages only' then the configure SSL button will show you the separate SSL tab so you can delete any settings in there just in case they're interfering.

                        Mike

                        Edit: I see it's now solved. Great.
                        Hi Mike,
                        thanks for the reply. I hadn't noticed!!!!! Was so focused on seeing the Test text appearing!

                        So the cure after removing the SSL in Business Settings and Making Sure there are no https in Network settings is to make a small change to the home page to force the removal of SSL.

                        Thanks for all your suggestions guys, got me to where I need to be.

                        Now, to ring the shower that's sales to chase the software upgrade quote - would have thought that was easy but still waiting for the quote.

                        John.
                        John
                        Sheltons Fishing Tackle
                        www.sheltonsfishing.co.uk
                        sigpic

                        Comment

                        Working...
                        X