Announcement

Collapse
No announcement yet.

Cannot Upload site to server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot Upload site to server

    I have happily been uploading updates to my server until today.
    I had a while ago installed a trial FTP package which has just ended yesterday, but was not aware this could affect Actinic. The end of the FTP application trial period seems to have caused this problem.

    On the reviewing files section of the upload the error message is:

    "Error accessing the installation destination directory.

    Possible Cause:
    The path From CGI-BIN to the acatalog directory is incorrect
    The network timed out
    The network is disconnected
    Recommendation:
    Abort
    Resolution:
    Run the Web | Configure Web Site Details command to verify your setup
    Re-establish the network connection
    Try again when the network is not so busy"

    When I close I get a dialogue box message "Error getting the current FTP working directory."

    On running a test on the network settings I got the following message.

    "Unable to move to the acatalog directory "../" on the FTP server possibly due to a mistake in the Path from CGI-BIN to acatalog Directory field.
    (null)."

    I have since unistalled the other FTP application but the problem remains. Does anyone know how to fix actinic to allow further uploads.
    www.calmncomfy.co.uk : Improving well being and enjoyment of life - Naturally

  • #2
    Are you still experiencing the problem?

    You are not alone on this issue
    http://community.actinic.com/showthread.php?t=14643

    I am trying to track th cause of this down for a client of ours as well.
    Testing their network settings from a different machine on a different connection shows that the ftp upload (certainly the network tests) are operating correctly.
    This would indicate either a firewall software/hardware update or possible an ISP based issue.
    Until the common setting/ISP/firewall is identified we will be unable to find where the problem lies.
    Perhaps you could list your Firewall software/hardware and ISP here in the hope of establishing a pattern.
    Fergus Weir - teclan ltd
    Ecommerce Digital Marketing

    SellerDeck Responsive Web Design

    SellerDeck Hosting
    SellerDeck Digital Marketing

    Comment


    • #3
      My site is hosted by Touch PLC whom I believe use Pipex. I have Version 4, Windows XP up to date, Norton Firewall, wireless network, router firewall and a headache!

      I have taken down everything and manually ftp'd, checked file structures, run everything under the sun that I can think of (4.00am) and have concluded that I can talk to the server OK from Actinic BUT it will not switch directories. All permissions seem OK.

      Seems to me the best plan at the moment is to suspend my catalog locally, generate the files and upload everything manually to stop order processing. Order download works fine. The only other issue I came accross was when I tried to "Configure Website Details..." it failed at the perl stage with a message that "the server is not configured to handle cookie headers" - has this anything to do with this issue or is it a red herring?

      PLEASE HELP!

      Can someone please confirm that they can CURRENTLY upload their site WITHOUT hitting this problem.
      Paul Codman
      <a href="http://www.snoozeshop.com/acatalog/index.html" target="_blank">www.snoozeshop.com</a>
      01394 670970

      Comment


      • #4
        Yes. Ok on 1and1. I ran an update about 10 minutes ago (using v6.1.5).

        Mike

        PS. The cookie header check message is a red herring and no longer tested on V5 upwards. See: http://community.actinic.com/showthread.php?t=5338
        -----------------------------------------

        First Tackle - Fly Fishing and Game Angling

        -----------------------------------------

        Comment


        • #5
          If you have Norton installed then please try the following:
          Access Nortons control panel area and enter the Intrusion Detection setup.
          Untick the check box and select the drop down to disable intrusion detection for 5 minutes then try another update from actinic to check if it fixes the problem.
          This resolved the issue for one machine that was having this problem.
          I would also check that norton have not ran a recent update as it does seem strange that this issue is affecting several people at the same time.
          Fergus Weir - teclan ltd
          Ecommerce Digital Marketing

          SellerDeck Responsive Web Design

          SellerDeck Hosting
          SellerDeck Digital Marketing

          Comment


          • #6
            Thanks for confirming the red herring Mike. I have tried changing the path from the CGI-BIN directory to Catalog directory to various options - it seems that as soon as you nedd to go UP the directory tree then you cannot. I have "ignore passive transfers" checked when I test the Network set up.

            My jump path is "../html/acatalog/" but the test message returns:
            "Unable to move to the catalog directory "../html/" on the FTP server.
            (null)" - seems like we are getting lost on the server somehow or other.
            Paul Codman
            <a href="http://www.snoozeshop.com/acatalog/index.html" target="_blank">www.snoozeshop.com</a>
            01394 670970

            Comment


            • #7
              Just a quick nudge Paul. It looks like you posted at about the same time as fergus and may not have seen his post.

              Mike
              -----------------------------------------

              First Tackle - Fly Fishing and Game Angling

              -----------------------------------------

              Comment


              • #8
                Hi Fergus / Mike

                Mike - thanks for the nudge, I hope that you are keeping well - long time, no chat!

                Fergus - What a star!

                Brilliant, I was working my way through disabling each part of Norton Antivirus, and read your message, being somewhat disinclined to disable it completely. Anyways, disabling the Intrusion detection fixed the issue here - what I find strange is that within Norton it does not report any attempted intrusion. Time for some methodical analysis to try to pin down exactly what the problem is.

                Many thanks.
                Paul Codman
                <a href="http://www.snoozeshop.com/acatalog/index.html" target="_blank">www.snoozeshop.com</a>
                01394 670970

                Comment


                • #9
                  Glad that fixed it.
                  One for further investigation.
                  Norton released a Gateway Security update on 20th of this month.
                  This looks like the culprit.
                  http://securityresponse.symantec.com...005.06.20.html

                  Looks like this new update does not like some of actinics ftp requests during an upload.
                  Fergus Weir - teclan ltd
                  Ecommerce Digital Marketing

                  SellerDeck Responsive Web Design

                  SellerDeck Hosting
                  SellerDeck Digital Marketing

                  Comment


                  • #10
                    thank you

                    with the actinic support lines permenantly engaged your post was invaluable. Any idea how to fix the problem permenantly?

                    big thanks

                    Comment


                    • #11
                      A quick update - I have managed to isolate MY problem to the following:

                      Go to "Intrusion Detection" then "Configure" then "Advanced" then find the Item "FTP Pathname Glob BufferOverflow" and uncheck the item. Click "OK, Click "OK". Then try to update the website. Then go back and set the item back to checked for now as I have no idea what this item is all about - time to investigate further unless someone can enlighten me.
                      Paul Codman
                      <a href="http://www.snoozeshop.com/acatalog/index.html" target="_blank">www.snoozeshop.com</a>
                      01394 670970

                      Comment


                      • #12
                        I believe that the Norton update to the intrusion detection has resulted in Norton identifying Actinic's upload ftp process as an intrusion. Quite a problem.
                        I do not use Norton firewall/internet security so it's going to be tricky for me to test any permanent settings that would solve this problem.
                        Maybe someone else might have more Norton experience that me?
                        Fergus Weir - teclan ltd
                        Ecommerce Digital Marketing

                        SellerDeck Responsive Web Design

                        SellerDeck Hosting
                        SellerDeck Digital Marketing

                        Comment


                        • #13
                          and just like that Paul has an answer.
                          Fergus Weir - teclan ltd
                          Ecommerce Digital Marketing

                          SellerDeck Responsive Web Design

                          SellerDeck Hosting
                          SellerDeck Digital Marketing

                          Comment


                          • #14
                            Bingo! Started to get this exact problem this morning. Disabled FTP Pathname Glob BufferOverflow in Norton and all is resolved.

                            Don'tcha just love Symantec?

                            Comment


                            • #15
                              I find it a bit strange that what appears to be the issue is not a part of the latest update that Fergus referred to.

                              Perhaps, someone at Actinic could advise further regarding leaving this particular intrusion threat permananently turned off in Norton or perhaps speak to Norton about the issue that has been caused.

                              If you want to confirm that this is the specific problem then go to Norton Internet Security then Statistics the View Logs and you should see the answer before your very eyes:

                              "Details: Intrusion Detection Signature File Version: 10/06/2005 Rev. 11.
                              Intrusion Detection Engine Version: 2.0.0.50609." is the original source of this issue - my signature file changed in the very early morning of 21 June 2005.
                              Last edited by Snooze_Shop; 22-Jun-2005, 11:48 AM. Reason: Further update!
                              Paul Codman
                              <a href="http://www.snoozeshop.com/acatalog/index.html" target="_blank">www.snoozeshop.com</a>
                              01394 670970

                              Comment

                              Working...
                              X