Announcement

Collapse
No announcement yet.

Product Embed Video Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Product Embed Video Error

    V16.1.2

    I have been trying to get an MP4 video to run in as a Popup Page generated from a Product Entended Information text link but have not been able to get this to work with html URL code link in the text or [LINK] with Advanced Link URL set up.

    The [LINK] function works correctly when placed in the Product Description but this links in a complete new window making it necessary to press the browser back button to get back to the product page which is not what I want.

    I just wondered if the "ProductEmbedVideo" error in the post link below:
    https://community.sellerdeck.com/for...publish-to-web
    Click image for larger version

Name:	ProductEmbedVideoError.jpg
Views:	67
Size:	28.4 KB
ID:	555140
    SD3078 bug - that appears not to have been resolved may have something to do with this or am I missing something?

    Martin
    Mantra Audio

    #2
    In what way specifically does it not work?

    Note that the ProductEmbedVideo expects a link to a hosted video - ie a sharing URL from somewhere like YouTube or Vimeo. You can't just upload an MP4 to your webspace and add a link to it - your web server almost certainly won't support that.

    If you are using a video hosting service, what happens if you ignore the error and upload anyway? (You can do it in Test Mode if you don't want to risk it live). Does the video appear in the popup page, or not? That would tell you whether the coding error is spurious (it can happen sometimes, unfortunately, the error checking is pretty complicated), or whether there's something wrong or inapproriate about the actual link.
    Bruce Townsend
    Ecommerce Product Manager
    Sellerdeck Ecommerce Solutions

    Comment


      #3
      Martin,

      We didn't find the built in video very good for our use.

      We host our videos at Cloudflare and setup a layout with their code. We also setup a a varaible for each specific product video so we only need to drop the code in.

      As Bruce says it depends on where your videos are hosted.

      Regards

      Jason

      Titan Jewellery (Swift Design)

      New Black Zirconium Rings
      New Tantalum Rings
      New Meteorite Rings

      Comment


        #4
        I have an old copy of your site here and it opens YouTube videos in a popup Extended Info Page window correctly on my local server. I just pasted the YouTube / Share / Embed / Copy text into SD's Extended Information / Embed Video field.

        It also works if I paste the same embed code into the Extended Information / Text field, surrounded by !!< and >!!

        The videos even appear in the Preview pane when the Extended Information tab is selected.

        It would help if you post details of what you're doing.
        Norman - www.drillpine.biz
        Edinburgh, U K / Bitez, Turkey

        Comment


          #5
          Thank you Bruce, Jason and Norman for your consideration and responses.

          I managed to get the video to work correctly by embedding code into the Extended Information / Text field surrounded by !!< and >!!
          Code:
           !!<<video controls width="360">
          
          <source src="https://shop.mantra-audio.co.uk/acatalog/*.mp4"
          type="video/mp4">
          
          Sorry, your browser doesn't support embedded videos.
          </video>>!!
          I consulted my web server host and they advised that they do not have any issues linking to an MP4 video on our web space but I appreciate this kind of file may be subject to specific security malicious code vulnerabilities.

          Could this still be a problem with an MP4 video made available to download from a reputable source for guidance/marketing purposes?

          Finally I think the "ProductEmbedVideo" error seen on upload must be a spurious error of some sort as the site uploads normally when this error is ignored and the video can still be seen in the extended information popup link:
          https://shop.mantra-audio.co.uk/acat...5.html#SID=165

          Martin
          Mantra Audio

          Comment


            #6
            Not sure why you have the *.mp4 as the filename. I used
            Code:
            <video controls width="360">
            <source src="https://shop.mantra-audio.co.uk/acatalog/Zerostat3v2.mp4"
            type="video/mp4">
            Sorry, your browser doesn't support embedded videos.
            </video>
            In the Embed Video field and it works fine. Also the same in works in the Text field surrounded by !!< and >!!. I put the video file in the root of the Site folder and added it via Design / Additional Files to be sure it got uploaded.

            It shows in the Preview pane (with the Extended Information tab selected) and also when doing a full site Preview.
            Norman - www.drillpine.biz
            Edinburgh, U K / Bitez, Turkey

            Comment


              #7
              Originally posted by NormanRouxel View Post
              Not sure why you have the *.mp4 as the filename
              That's fine, Norman I used the full file name in the Extended Information Text field.
              Thank you for the tip on using Design / Additional Files to make sure the file(s) get uploaded.

              Martin
              Mantra Audio

              Comment

              Working...
              X