Announcement

Collapse
No announcement yet.

Mulitple Sellerdeck Software Malfunctions

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mulitple Sellerdeck Software Malfunctions

    Hi everyone,
    I've had a client today call me to say her website is not displaying her products at all. I've taken a look and sure enough the preview within the software isnt recognising the products, even though they are in the content tree.

    I also had another client yesterday call me regarding their website not working. When I looked at their issue it seems that the software wasnt recognising the products also?

    Just to clarify these two clients are on version 16.0.3 but on different hosts, one of which is Sellerdeck.

    Is anyone else experiencing any similart problems. Could their be a specific piece of javavscript with the software core that may be become redundant? Any feedback, help or guidance is appreciated.

    Below is a screen shot of the errors that have just started appearing.

    Click image for larger version

Name:	errors.jpg
Views:	1
Size:	41.0 KB
ID:	550432
    Regards.

    Lee Jackson
    Creative Director

    Centurius Design & Marketing
    Centurius Website
    Portfolio of Work

  • #2
    All those errors point to the SellerDeck supplied JavaScript files not being detected at page generation time and thus not being uploaded to the server. This is either a single file "sellerdeck.min.js" or a collection of individual files if any of the individual files have been altered.

    A link to a faulty site would help.
    Norman - www.drillpine.biz
    Edinburgh, U K / Bitez, Turkey

    Comment


    • #3
      H Norman,
      Link to site attached.

      Many thank BTW.
      Regards.

      Lee Jackson
      Creative Director

      Centurius Design & Marketing
      Centurius Website
      Portfolio of Work

      Comment


      • #4
        Weird behaviour. When I first went to https://www.ajmrailways.com no scripts or CSS files loaded.

        Then I tried plain http://www.ajmrailways.com and the site works. Strangely, it then worked when I went back to https.
        Norman - www.drillpine.biz
        Edinburgh, U K / Bitez, Turkey

        Comment


        • #5
          Hi Norman,
          I've just spoke to my client and she had her hosting provider roll back the site to the last 24 hours when it was working so all looks as it should. Her software is still incorrect so she won't upload the site as it will override the rollback. By the lack of response I'm guessign this issue may be related on to me. I'll dig deeper into it on Monday and speak to Sellerdeck regarding this. If I have no joy with them then I may be back in touch with yourself to see if I can hire you to do some further investigation for me. In the meantime many thanks for looking.
          Regards.

          Lee Jackson
          Creative Director

          Centurius Design & Marketing
          Centurius Website
          Portfolio of Work

          Comment


          • #6
            I just had an almost identical problem on another site using my NorPrice currency converter.

            Looks like something at the European Central Bank Data Feed (which NorPrice loads when viewing the Home Page) is poisoning SellerDeck's PHP (which is used to process BlockIf's) and subsequently causing numerous weird errors.

            Email me for a fix.
            Norman - www.drillpine.biz
            Edinburgh, U K / Bitez, Turkey

            Comment


            • #7
              Norman,
              Just wanted to say many thanks for the fix. The design snapshot provided did the trick and all the affected sites are back up and running successfully!
              Regards.

              Lee Jackson
              Creative Director

              Centurius Design & Marketing
              Centurius Website
              Portfolio of Work

              Comment


              • #8
                Fix for sites (all SD versions) where NorPrice is the culprit now posted on http://www.drillpine.biz/forums/viewtopic.php?f=7&t=1030
                Norman - www.drillpine.biz
                Edinburgh, U K / Bitez, Turkey

                Comment


                • #9
                  Hi Norman - hope you're well? Trying the fix. We've had a similar issue from Thu/Fri where product pages are not fully generating/displaying offline, unfortunately these were published before we noticed. We're using Norprice on those pages. Also, the following error message when accessing orders:

                  Code:
                  A serious error occurred: failed to call the PHP tax calculation module. Try reinstalling the product. If the error still occurs, please contact SellerDeck support: could not parse response XML
                  UPDATE: replacement of norpricegetecbrates.php as the fix has worked for us - thanks for prompt provision of this Norman.
                  Last edited by musicscotland; 10-Sep-2018, 05:09 PM. Reason: update on fix
                  Kenny Fraser
                  http://kennyfraser.com

                  Comment


                  • #10
                    I've just updated my fix for sites (all SD versions) where NorPrice is the culprit to make it more resilient.
                    Updated fix posted on http://www.drillpine.biz/forums/viewtopic.php?f=7&t=1030
                    Norman - www.drillpine.biz
                    Edinburgh, U K / Bitez, Turkey

                    Comment


                    • #11
                      I am having the same exact issue with a client with three sites. Everytime I think it is fixed it reverts to being broken when you reopen the software. I will try your fix shortly. Thank you.
                      Jonathan Chappell
                      Website Designer
                      SellerDeck Website Designer
                      Actinic to SellerDeck upgrades
                      Graphicz Limited - www.graphicz.co.uk

                      Comment

                      Working...
                      X