Announcement

Collapse
No announcement yet.

Cart problems - software, server or SSL? ​

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cart problems - software, server or SSL? ​

    Hello. For some time now I have been receiving intermittent reports from customers saying that they have trouble adding products from my site into the cart. Sometimes they are unable to add a single product, sometimes it starts playing up after two or three products are added and wonít let them add any more. Yesterday I replicated trying to order a product a customer was having a problem with and the same thing happened to me - after I 'added' it the cart remained empty. Then I switched from iPad to desktop and was able to add the same product to the cart okay. The customer was able to order the product fine later in the day.

    These issues have only really begun since I switched from v12.0.6 to version 16.0.4 in January. I use 16.0.4 as it rectified a digital download issue found in 16.0.3.

    However, when I uploaded my site using this new version, I also switched from no SSL to full SSL, and switched on the redirects on my (shared) server control panel.

    These occasional cart issues started happening pretty much from that point onwards, but Iíve never been sure if itís SSL or Sellerdeck code that is causing the problem. It may also be the shared server of course, although it didnít seem to cause such problems before I started using SD 16.0.4 and SSL in January. I wonder if switching to Sellerdeck 18.0.2 might help, although I am reticent to upgrade unless I have to.

    Can anyone suggest what might be going wrong when 'add to cart' doesn't do what it's supposed to?

    Thanks very much for any advice
    Paul

  • #2
    It does sound like SSL.... but a URL would be helpful....
    Elysium:Online - Official Accredited SellerDeck Partner
    SellerDeck Design, Build, Hosting & Promotion
    Based in rural Northants

    Comment


    • #3
      Thanks Goz. My homepage is here

      Comment


      • #4
        I've had a little look around.... I can kind of replicate what you are describing.

        If you add something to your cart, you then need to click one of the 3 buttons that appear - either "Continue", "Checkout Now" or "Cancel". It does appear that it has added to card but, until you click on one of those three the product is not actually added.

        If you add something to your cart and then click anywhere elsewhere apart from those 3 buttons then the product is not added to the cart.

        Does that fit in with what you are experiencing?

        Can you go into Design Options in the Design menu and tell me what the settings are for "Shopping Mode".
        Elysium:Online - Official Accredited SellerDeck Partner
        SellerDeck Design, Build, Hosting & Promotion
        Based in rural Northants

        Comment


        • #5
          The setting I have for shopping mode is Quantity on Confirmation Page, and bounce page delay is 7 seconds.

          Yes, in order to successfully add a product to cart a customer has to click 'Continue' - the trouble is that on occasions after doing so the cart is still empty, itís as though pressing 'Continue' hasnít registered. Sometimes this can be enough to throw the customer off the site and 503 Bad Gateway errors start occurring soon afterwards.

          Comment


          • #6
            Intruiged about why you've got quantity on confirmation page. Why did you choose to use that?
            Elysium:Online - Official Accredited SellerDeck Partner
            SellerDeck Design, Build, Hosting & Promotion
            Based in rural Northants

            Comment


            • #7
              Hmm, good question. It probably goes back right the way to when I first designed the site in Actinic v7, when I really didn't know much about how to set things up. As my products were electronic I wanted to ensure the quantity for each product could not be changed, and I guess I decided this was the best way, can't quite remember though! Might setting it to quantity on product page or bypassing the bounce page work better, wouldn't that still require someone to click a 'continue' button?

              I'm still confused as to why when I pressed continue after making adding a product to cart it occasionally doesn't recognise anything has been added. If it is SSL related, should I perhaps add something to an htaccess file in addition to the redirects I've turned on at my server control panel, or might this confuse things further? Thanks for your continuing help.

              Comment


              • #8
                It might be worth changing that to Quantity On Product Page and ticking "Order Quantity Always One" (Business Settings > Ordering tab) and seeing if that improves things. Also, maybe change the Bounce page delay to 5 seconds.... I think 7 seconds is too long.
                Elysium:Online - Official Accredited SellerDeck Partner
                SellerDeck Design, Build, Hosting & Promotion
                Based in rural Northants

                Comment


                • #9
                  Okay, that's a good idea, it didn't occur to me that I could try this. I might try changing the shopping mode for one or two products first (using the Page Settings tab on each section) and seeing how that works. Thanks.

                  Comment

                  Working...
                  X