Announcement

Collapse
No announcement yet.

Real-Time Stock Display disappearing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Real-Time Stock Display disappearing

    Can anybody shed some light on this please?

    I've found that with out-of-the-box V18, Real-Time Stock Display only works if dynamic pricing is enabled. If I set UseDynamicPrices to "false", the RTS display disappears. Should this be happening and is there a way to fix it? I want to replicate my live 2016 site which has static prices and RTS display. Any pointers would be appreciated.

    Thank you,
    John
    John Ennals
    www.tortoys.co.uk

  • #2
    Hi John. That wouldn't normally happen, and it's not something I've ever experienced or heard of. If you have a Cover contract, I suggest contacting Support about it.
    Bruce Townsend
    Ecommerce Product Manager
    Sellerdeck Ecommerce Solutions

    Comment


    • #3
      Unless I'm going mad (which is quite possible as I'm now on the 6th day of trying to upgrade from 2016 to V18), the issue seems to be present in V18, newly installed and without modification; I've tried it on two separate PCs.

      I've worked round it by setting both UseDynamicPrices and OverrideStaticPrice to "True".
      John Ennals
      www.tortoys.co.uk

      Comment


      • #4
        I'm not going mad. The problem appears to be related to some new code that Sellerdeck have added to actincextras.js in V18 and which is not present in actinicextras.js in SD2017. It's at lines 585-591:
        Code:
            //
            // If there are no products in the page, don't get any stock
            //
            if ($.isEmptyObject(g_mapProds))
                {
                return "";
                }
        If I delete these lines, RTS display remains visible as it should do when I set UseDynamicPrices to "false".

        Unfortunately I've gone beyond the limits of my knowledge with this and I'm not sure whether it is actually a bug or whether I've configured something wrongly somewhere else.

        Edit: I'm guessing this code relates to the bug fix in V18: "Eliminated redundant calls to get stock and prices, SD-6990"
        John Ennals
        www.tortoys.co.uk

        Comment


        • #5
          This bug has been "fixed" in V18.0.1.
          John Ennals
          www.tortoys.co.uk

          Comment

          Working...
          X