Announcement

Collapse
No announcement yet.

Email totals missing a digit...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email totals missing a digit...

    I've noticed recently emails totals cannot display more than 7 characters

    See attached image...

    Attached Files

  • #2
    You could save a couple of digits via Settings / Business Settings / Options / Currency Settings and choosing "£" instead of "GBP".
    Norman - www.drillpine.biz
    Edinburgh, U K / Bitez, Turkey

    Comment


    • #3
      That setting has been bugged for us since I reported it July 2015 - ref: Sellerdeck Bug : SD-5090
      - I reported when we started to have a support contract to resolve some severe perfomance issues
      - so this bug existed for us before 2015

      Once we changed from £ to GBP, we can't revert back.
      Attached Files

      Comment


      • #4
        You may be able to fix this by altering ActinicCatalog.mdb using Microsoft Access. With SD closed look in the "Catalog" table for SCURRENCY and SINTLSYMBOLS and make changes there.
        Norman - www.drillpine.biz
        Edinburgh, U K / Bitez, Turkey

        Comment


        • #5
          I believe zgap is using SQL enterprise, in which case he would need to make the same actions that Norman recommended in the SQL database.
          Matt. M - SMR Enterprises Ltd.

          Comment


          • #6
            Yes, we're on SQL...

            So far:

            ========================

            #1 :
            I don't know what to change, so I created a demo site and exported the "catalog" table to compare the differences:

            I created a demo site and then exported the catalog table for both "£" / "GBP" settings.
            I compared the two files and the catalog table is exactly the same.

            So I don't know what changes to make - see image.

            Demo data has both as not selected - see image
            - if you select "£", ok, go back in, it's still both empty... I assume both empty = "£"?
            - if you select "GBP", ok, go back in, it's "GBP", and selecting "£" does nothing...
            - it's as though the "£" button actually has no code assigned to it...

            ========================

            #2 :
            Manually changing the GBP to £ in SQL

            SCURRENCY = "£"
            SINITLSYMBOLS = "GBP"

            I changed the SINITSYMBOLS to "£"
            Program crashes after login (send crash data to SD window appears...)
            Restoring it back to GBP = program loads.

            ========================

            If there is a solution... Let me know what to do exactly...
            Attached Files

            Comment


            • #7
              I've raised a bug report for this, SD-7793. You're extremely unlucky to hit two bugs that coincide in this way :-(

              Is there a particular reason why you cannot use £ instead of GBP?
              Bruce Townsend
              Ecommerce Product Manager
              Sellerdeck Ecommerce Solutions

              Comment


              • #8
                re: Is there a particular reason why you cannot use £ instead of GBP?

                The reason was bug SD-5090
                Is it only me who has this problem?

                Back in 2015:

                Unable to change to "£" sign... sticks to "GBP"
                Is there a field in the *.mdb file that changes this setting?
                Afraid not itís an interface setting issue so its in the code..

                Kiran Chandran

                Technical Support

                SellerDeck Ltd

                The following query that you logged with us has now been closed.

                Ticket reference: 75966
                Description: Business Settings > Options > Currency Settings : Problem
                Solution: Bug (ref. [SD-5090])

                This query has been caused by a bug. Although the query is closed, the bug will be reviewed for fixing in a future release. Please check the release notes for future releases at: http://www.sellerdeck.co.uk/index.ph...gory/downloads.

                Kiran Chandran | Technical Support | SellerDeck

                Comment


                • #9
                  OK, got it. If you have MS Access and you know how to use it, you can work around that issue, and restore use of the £ symbol, by changing the associated field in the database.

                  Open ActinicCatalog.mdb
                  Open the Setupinfo table
                  Scroll down to the entry 'Use currency symbol in receipt emails' (nID = 30)
                  Change the vaue of sData to -1

                  The UI will show neither option selected, due to SD-5090, But the £ symbol will be used in emails because it is the default.

                  I have posted the above workaround to our internal ticket. So if you're not able to apply it, and you have Cover, then you can call support. They should now be able to find the workaround and apply it for you.

                  I hope this helps.
                  Bruce Townsend
                  Ecommerce Product Manager
                  Sellerdeck Ecommerce Solutions

                  Comment


                  • #10
                    We're on SQL... did the same change, and it works

                    Thanks Bruce - you solved two problems with 1 edit
                    Attached Files

                    Comment

                    Working...
                    X