Announcement

Collapse
No announcement yet.

GCI bin error when sending emails from the order tab

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GCI bin error when sending emails from the order tab

    Since changing the network settings in Sellerdeck for my new hosting I am advised of a situation where a cgi-bin error occurs when sending emails from the 'Orders' tab within Sellerdeck. This may be an anomaly where Sellerdeck retains and sometimes uses the old non secure FTP details in its database and calls on them. The SSL network settings are in table Setup3 in the database, the old Standard network settings are retained in Setup2. It is these settings that Sellerdeck uses when sending emails from the software. The HTML email template also uses the CatalogURL variable rather than the SSLCatalogURL one.

    This is the error
    Code:
     
     SellerDeck received a request forbidden error from the web server.  The server is not properly configured to allow SellerDeck to run CGI scripts from the cgi-bin.   Run Web | Configure Web Site Details... to review your web site configuration      Suggestions:      - Check that this folder exists on your server in the place specified in your 'Web | Network Setup' screen and that scripts are allowed to run in it (you may need to contact your host).    - Check the permissions:           On Linux/Unix based servers the permissions should be:    cgi-bin (755)  drwxr-xr-x          Online Store Folder (755)  drwxr-xr-x           On Windows based servers (need to be checked with the hosting company):     IIS    cgi-bin = read/execute           Online Store Folder = read/write/execute          NTFS    cgi-bin = Catalog's FTP account needs 'Change' permissions on the directory          Online Store Folder = Catalog's FTP account needs 'Change' permissions on the directory AND the IUSR_ account needs to have 'Change' permissions on the directory     - There could be a setting in your firewall that could cause this problem.   To test this try turning off your firewall while you perform the upload.   If the upload goes through ok then you will need to find the setting that is causing the problem.
    This is how to fix this:

    Go to Settings, Business Settings, Payment and security and by SSL tick only checkout, login and account pages only, then click Configure SSL/TLS settings. Make sure that the settings in the Standard tab are the same as in the SSL/TLS tab (except the web urls will be http not https - the Website URL will be https). Apply and OK, now tick Whole Site for Use SSL/TLS and publish to web and test.
    Jonathan Chappell
    Website Designer
    SellerDeck Website Designer
    Actinic to SellerDeck upgrades
    Graphicz Limited - www.graphicz.co.uk

  • #2
    Thanks Jonathan. I think this might solve an email problem that was posted on here about a week ago.

    Mike
    -----------------------------------------

    First Tackle - Fly Fishing and Game Angling

    -----------------------------------------

    Comment


    • #3
      Cool - please can you link to/from it in case it helps?
      Jonathan Chappell
      Website Designer
      SellerDeck Website Designer
      Actinic to SellerDeck upgrades
      Graphicz Limited - www.graphicz.co.uk

      Comment


      • #4
        I already posted a link to this one from it. You'll find the problem thread here https://community.sellerdeck.com/for...8-email-in-v18
        -----------------------------------------

        First Tackle - Fly Fishing and Game Angling

        -----------------------------------------

        Comment


        • #5
          Thanks Mike
          Jonathan Chappell
          Website Designer
          SellerDeck Website Designer
          Actinic to SellerDeck upgrades
          Graphicz Limited - www.graphicz.co.uk

          Comment

          Working...
          X