No announcement yet.

Site hangs on 'Saving your order" 100% CPU after server upgrade

  • Filter
  • Time
  • Show
Clear All
new posts

  • Site hangs on 'Saving your order" 100% CPU after server upgrade

    Hi All,

    Our hosts have migrated us to a new server and now we're having problems with the checkout process. They have been unable to find the problem for almost three weeks. Can anyone help?

    Symptoms: (We use WorldPay and PayPal)
    -If the customer chooses WorldPay, when they hit 'Confirm order' on the last stage of the checkout process, the button changes to 'Saving order' and hangs. Eventually, it returns with '504 Gateway timeout' in the area below the button.
    -if they choose PayPal, they are directed to PayPal as normal, complete the payment, but when it's time to return to our site, there's no response and eventually gives a white page with '504 Gateway timeout'. We never get to see the order which they have placed... and paid for!

    In both cases, we can see that the server CPU is maxed out at 100%. Looking at the logs, we can see that it is the script which is using all the CPU, although the hosts say it's not actually doing anything, just waiting.

    Has anyone seen these symptoms before?

    (I've uoloaded the site to another host and it works fine there, but it'll be a pain to shift it!)

    We'd love some help on this, it's driving us all MAD!

    The site is -I can't find where to change my signature!

    Thanks! -Jc.

    more detail:

    The site's been running fine for years without any recent updates. We've tried loads of things:
    -incrementing the script number
    -checking the file and folder permissions
    -check Perl modules are installed (see below)
    -sufficient disk space

    Troubleshooting, website analysis shows that permissions are fine, SMTP comms are ok and the following scripts are installed:

    Digest::MD5 Installed
    ActinicEncrypt1024 Not installed
    Exporter Installed
    File::Temp Installed
    LWP::UserAgent Installed
    Crypt::SSLEasy Not installed**
    CGI Installed
    CGI::Carp Installed
    Archive::Zip Installed
    Net::SSL Installed

    ** we've checked and 'Crypt::SSLeay' IS installed

  • #2
    There are a few suggestions in this thread that are worth looking at

    First Tackle - Fly Fishing and Game Angling



    • #3
      Hi Mike,

      Thanks for suggesting those -tried 'em all!

      But, just re-tried something that I had tried before (or thought I had!) and it's showing promise -a newer version of I've just tried it on a test site and it's fixed the problem.

      I'm going to give it a go on the live site now and will report back.

      here it is:

      I'll let you know....


      • #4
        It worked!!

        Big thanks to Lance from brightkidz four years ago in this post:

        I'd done the edit the first time, but must have got it wrong, so this time, I found a more recent version of the file (in Sellerdeck 2013) and popped it in the site1 folder.

        I hope this helps someone else along the way.

        Cheers! -Jc.