Announcement

Collapse
No announcement yet.

SSL problems with Webfusion Reseller Server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SSL problems with Webfusion Reseller Server

    I have just purchased a SSL certificate to implent on my website which is hosted on a Webfusion Reseller server.

    I have had the site working OK for several months on this server without SSL.

    I have now set the website up to use SSL on the checkout pages only but when I test uploading the site using the attached settings I get the error message
    An error occurred in the secure channel support
    followed by
    The test script failed to execute on the web server. The error could be caused by several things. Check the path to the Perl shell, the CGI script extension, the path to CGI-BIN, and the CGI-BIN URL. This error could also occur if your web site is out of disk space or your web server is not configured to accept POSTs to CGI scripts
    If I attempt to use SSL on the site I get the error message as per the attached image when clicking on the checkout button

    I have attached my Actinic network configuration

    Anybody got any suggestions?
    Attached Files
    Regards
    David

    www.theoriginalsin.co.uk
    Website Design & Development

  • #2
    Strange, I can't see any sign of an SSL certificate on the site.

    Has the certificate been installed (or whatever they have to do) on the server?

    Mike
    -----------------------------------------

    First Tackle - Fly Fishing and Game Angling

    -----------------------------------------

    Comment


    • #3
      Hi Mike - you could be right.

      I received an email from them to say it was set-up and working and assumed it was.

      I've just used a tool to check and it appears it has not been. I'll let you know how I get on.
      Regards
      David

      www.theoriginalsin.co.uk
      Website Design & Development

      Comment


      • #4
        David, if the site has a valid and active SSL certificate, a simple check is to substitute https:// for the http:// in front of the URL. That should initiate a secure connection. If it falls over then there is a problem somewhere.

        It looks as if it still hasn't been installed for the above site.

        Comment


        • #5
          Mmmmm - a strange one this

          Webfusion said for SSL to work required a change to the DNS A record, and I should have received an email telling me to change this - which I didn't. Webfusion made this change for me.

          Once it had propogated down I found that I was unable to see my site in the browser - instead it displayed an error message about access being forbidden.

          I contacted Webfusion again who said that there was some code in my .htaccess file that was causing the problem. They got the site back by deleting the .htaccess file.

          So SSL now works.

          Inside the .htaccess file was the following code which I remember putting in there at the request of Webfusion - I can't remember what for - was it to allow php code to run in html page?


          #Options +FollowSymLinks
          #RewriteEngine on
          #RewriteCond %{HTTP_HOST} ^enjoy.co.uk [NC]
          #RewriteRule ^(.*)$ http://www.enjoy.co.uk/$1 [L,R=301]
          Regards
          David

          www.theoriginalsin.co.uk
          Website Design & Development

          Comment


          • #6
            #Options +FollowSymLinks
            #RewriteEngine on
            #RewriteCond %{HTTP_HOST} ^enjoy.co.uk [NC]
            #RewriteRule ^(.*)$ http://www.enjoy.co.uk/$1 [L,R=301]
            I think this is code to direct non-www urls to the www version. If the whole site is now under https I guess you might be able to put the code back into your htaccess file but change the http to https, although I am inexperienced with these things so I would wait until someone with more knowledge confirms this.
            Darren Guppy
            Golf Tee Warehouse
            Golf Tees and Golf Accessories.

            Comment


            • #7

              Webfusion said for SSL to work required a change to the DNS A record, and I should have received an email telling me to change this - which I didn't. Webfusion made this change for me.
              this is because SSL requires a website to be on a dedicated IP so i imagine the first issue was caused by the change to IP and subsequent propagation.

              Comment


              • #8
                #Options +FollowSymLinks
                #RewriteEngine on
                #RewriteCond %{HTTP_HOST} ^enjoy.co.uk [NC]
                #RewriteRule ^(.*)$ http://www.enjoy.co.uk/$1 [L,R=301]
                Thinking about it I might have put this code in because the SSL logo was not showing for the non www version.
                Regards
                David

                www.theoriginalsin.co.uk
                Website Design & Development

                Comment


                • #9
                  I thought the # commented the line out. Is this not the case with webfusion?
                  Jonathan Chappell
                  Website Designer
                  SellerDeck Website Designer
                  Actinic to SellerDeck upgrades
                  Graphicz Limited - www.graphicz.co.uk

                  Comment


                  • #10
                    I thought the # commented the line out. Is this not the case with webfusion?
                    Yeah, the # comments out for everybody.

                    I can only assume that at some point it was live then commented out - lost my train of thought on this thread maybe due to it being 9 years old ...
                    Regards
                    David

                    www.theoriginalsin.co.uk
                    Website Design & Development

                    Comment

                    Working...
                    X